[FFP] 1043er auch mal im AP mode

Thomas Janda tj at porga.de
So Nov 3 17:19:17 CET 2013


Hallo Menschen,

ich benötige Hilfe/einen Hinweis mit einem Problem, das mir des Öfteren
begegnet. Ich möchte momentan fürs Projekthaus Babelsberg die gleiche
Standardkonfiguration vornehmen, wie fürs pub-a-la-pub.

In der Kneipe/Begegnungsstätte: WR1043ND im AP Modus
Aufm Dach: M2 (oder eben M5) zur Anbindung ins Netz (oder Backbone).
Verbunden sind die beiden mittels Kabelkopplung.

Nun mein Problem:
Immer wenn ich versuche den WR1043ND in den AP Mode zu bringen,
scheitert irgendetwas, denn das Interface (wlan0) kommt nun gar nicht
mehr hoch -> Die Meldung in der GUI lautet: WLAN ist deaktiviert oder
nicht assoziiert

Ich habe es auch mit genau der gleichen config vom pub-a-la-pub probiert
(rübergebügelt und mac/ip adressen ausgetauscht). Das Problem bleibt
genau das gleiche (Wifi startet nicht).

Kennt jemand das Problem und kann mich mit einem kleinen Hinweis
erlösen? Dann wäre mein ganzer Vormittag doch nicht dahin gewesen.

Grüße in die Runde
Tommy


Hier die wireless und die network config:

/etc/config/wireless (powered by imagebuilder)

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr '64:70:02:fd:26:cc'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'DSSS_CCK-40'
    option diversity '1'
    option hwmode '11g'
    option distance '1000'
    option bssid '02:CA:FF:EE:BA:BE'
    option disabled '0'
    option country 'DE'
    option channel '5'

config wifi-iface 'radio0_iface'
    option device 'radio0'
    option encryption 'none'
    option mode 'adhoc'   # <- danach eben 'ap'
    option bgscan '0'
    option sw_merge '1'
    option mcast_rate '5500'
    option probereq '1'
    option network 'wireless0'
    option ssid 'www.freifunk-potsdam.de'
    option bssid '02:CA:FF:EE:BA:BE'

dazugehörige /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '2'
        option ports '0 5t'

config interface 'wireless0'
        option dns '8.8.8.8 212.204.49.83 141.1.1.1'
        option netmask '255.255.0.0'
        option proto 'static'
        option ipaddr '10.22.9.32'

config interface 'wireless0dhcp'
        option ifname '@wireless0'
        option proto 'static'
        option ipaddr '6.9.32.1'
        option netmask '255.255.255.0'







-------------- nächster Teil --------------
Ein Dateianhang mit HTML-Daten wurde abgetrennt...
URL: <http://lists.freifunk-potsdam.de/pipermail/users/attachments/20131103/d19cdf52/attachment-0004.html>
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname   : signature.asc
Dateityp    : application/pgp-signature
Dateigröße  : 901 bytes
Beschreibung: OpenPGP digital signature
URL         : <http://lists.freifunk-potsdam.de/pipermail/users/attachments/20131103/d19cdf52/attachment-0004.pgp>


Mehr Informationen über die Mailingliste Users